Bu uyarı oluşmuştur:
Warning [2] Cannot modify header information - headers already sent by (output started at /home/mybbkursu/public_html/inc/languages/turkish/showthread.lang.php:1) - Line: 1928 - File: inc/functions.php PHP 7.0.30 (Linux)
File Line Function
[PHP]   errorHandler->error
/inc/functions.php 1928 header
/inc/functions.php 1998 my_setcookie
/inc/functions_indicators.php 41 my_set_array_cookie
/showthread.php 664 mark_thread_read




Konuyu Değerlendir
  • 0 Oy - 0 Ortalama
  • 1
  • 2
  • 3
  • 4
  • 5
Sponsor Reklam
İpuçu MyBB Eklenti Sürümlerini 1.8 Sürümüne Yükseltme İşlemi
#1
1.6 Eklenti Sürümlerini, 1.8 Sürümüne Uyarlama İşlemi - [Ders]

Merhaba arkadaşlar, değerli MyBB kullanıcıları,

Bu konumuzda, forumları 1.8 sürümüne yükselttiğimiz zaman eklenti yönetiminde çıkacak olan şu uyarının çözümünü anlatacağım.

 Bu uyarı mesajını çözüme ulaştırmak için, hangi eklenti hata veriyorsa, ./plugins klasöründen bularak bilgisayarımıza indiriyoruz ve notepad++ programı ile açarak aşağıdaki resimde ''kırmızı kutu'' içinde imlediğim alanda eklenti sürümünü 1.8 sürümünde çalışacak şekilde ayarlıyoruz. Burada dikkat edilmesi gereken nokta, notepad++ ile dosyayı açtığınız zaman üsteki menüde yer alan ''UTF-8 Kodlaması (Bomsuz)'' seçeneğinin seçili olup olmadığını kontrol etmenizdir. Eğer, seçili değil ise mutlaka işlem yapmadan önce seçimi yapınız, aksi halde forumun hata vermesine neden olabilirsiniz..

Yapmanız gereken işlem oldukça basit ve düzenlemeniz gereken alan için uygulayacağınız alternatif çözümlerimiz bolca mevcut.

Düzenlenecek kısım:

Kod:
"compatibility" => "16*" 

Yapılması gereken:

Kod:
"compatibility" => "18*" 

Şöyle de olur ve tavsiye edilir:

Kod:
'compatibility' => '*' 

Kod Açıklamaları:

Kod:
'compatibility' => '16*'  Sadece 1.6.x serisi için
'compatibility' => '18*'  Sadece 1.8.x serisi için
'compatibility' => '16*,18*'  Tüm seriler için (1.6, 1.8)
'compatibility' => '*'  Tüm seriler için (1.6, 1.8) 

Son olarak şöyle bir durum daha var, Eklenti sürümü yükseltmek 1.8 sürümünde tam anlamı ile stabil çalışacağı garantisi verilmemekte çünkü, bilindiği gibi tema ve şablon sisteminde oldukça fazla değişiklikler yapıldı ve kimisi sorunsuz çalışırken kimiside aktif etseniz dahi görevini yapamayabilir. Bunun için de bizler elimizden gelen gayreti gösterip güncellenen eklentileri forumda paylaşacağız veya kendimiz bir şekilde uyarlamaya çalışacağız. Sürüm yükselttiğimiz halde çalışmıyorsa eğer yapacak birşey yok, güncellenmesini beklemekten başka ya da kendimiz güncellemekten başka..

Hatırlatma: Bazı eklentilerin çalışabilmesi için PluginLibrary eklentisini yüklemeniz gerekmektedir. Ama PluginLibrary eklentisi 1.8 ile uyumlu olmadığı için bu konudaki gibi güncellemeniz gerekmektedir.
Alıntı


Foruma Git:


Bu konuyu görüntüleyen kullanıcı(lar): 1 Ziyaretçi